PAT 1127. ZigZagging on a Tree (30)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in “zigzagging order” – that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

根据后续和中序来确定一棵树的算法前面已经写过好几次了,这里就不再复讲了。确定了树的结构,就可以知道层序遍历的结果了, 我这里把每一层的节点都分开存储,偶数层逆序输出,奇数层正序输出。 ps:我感觉我这个方法比较暴力,如果你有更好的方法,不介意的话可以跟我交流下呀~~

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
#include <cstdio>
#include <vector>
#include <queue>

using namespace std;

vector<int> in, post;

struct tree {
int val, level;
struct tree *left, *right;
};

int findRootInInorder(int inl, int inr, int val) {
for (int i = inl; i <= inr; i++) {
if (in[i] == val) return i;
}
return -1;
}

struct tree *buildTree(int inl, int inr, int postRoot, struct tree *root, int level) {
if (inl > inr) return NULL;
if (root == NULL) root = new struct tree();
int inRoot = findRootInInorder(inl, inr, post[postRoot]);
root->val = post[postRoot];
root->level = level;
root->left = buildTree(inl, inRoot - 1, postRoot - inr + inRoot - 1, root->left, level + 1);
root->right = buildTree(inRoot + 1, inr, postRoot - 1, root->right, level + 1);
return root;
}

vector<vector<int> > getLevelOrder(struct tree *root) {
vector<vector<int> > levelOrder(30);
queue<struct tree *> q;
q.push(root);
while (!q.empty()) {
struct tree *t = q.front();
q.pop();
levelOrder[t->level].push_back(t->val);
if (t->left != NULL) q.push(t->left);
if (t->right != NULL) q.push(t->right);
}
return levelOrder;
}

void printZigZag(vector<vector<int> > levelOrder) {
printf("%d", levelOrder[0][0]);
for (int i = 1; i < levelOrder.size(); i++) {
if (i % 2 == 0) {
for (int j = levelOrder[i].size() - 1; j >= 0; j--) {
printf(" %d", levelOrder[i][j]);
}
} else {
for (int j = 0; j < levelOrder[i].size(); j++) {
printf(" %d", levelOrder[i][j]);
}
}
}
}

int main() {
int n = 0;
scanf("%d", &n);
in.resize(n);
post.resize(n);
for (int i = 0; i < n; i++) {
scanf("%d", &in[i]);
}
for (int i = 0; i < n; i++) {
scanf("%d", &post[i]);
}

struct tree *root = buildTree(0, n - 1, n - 1, NULL, 0);
vector<vector<int> > levelOrder = getLevelOrder(root);
printZigZag(levelOrder);
return 0;
}