PAT 1136. A Delayed Palindrome (20)

Consider a positive integer N written in standard notation with k+1 digits ai as ak…a1a0 with 0 <= ai < 10 for all i and ak > 0. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 and is also palindromic by definition. Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number) Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C

where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number – in this case we print in the last line “C is a palindromic number.”; or if a palindromic number cannot be found in 10 iterations, print “Not found in 10 iterations.” instead.

Sample Input 1:

97152

Sample Output 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

Sample Input 2:

196

Sample Output 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

验证一个数加上逆转它之后得到的数是否为一个回文数。 输入的数值不超过1000位,所以不可以用int或者long存储,而必须用string存储。 算法的思路很常规,将输入的数值reverse并加上数值本身,并判断它是否是回文数即可。见代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
#include <iostream>
#include <string>
#include <algorithm>

using namespace std;

bool isPalindrome(string s) {
string t = s;
reverse(t.begin(), t.end());
return t == s;
}

string add(string s, string t) {
int carry = 0;
string result;
for (int i = 0; i < s.length(); i++) {
result += (s[i] + t[i] - '0' - '0' + carry) % 10 + '0';
carry = (s[i] + t[i] - '0' - '0' + carry) / 10;
}
if (carry != 0) result += carry + '0';
reverse(result.begin(), result.end());
return result;
}

int main() {
string s, t, sum;
cin >> s;
int cnt = 0;
while (!isPalindrome(s) && cnt < 10) {
cnt++;
t = s;
reverse(t.begin(), t.end());
sum = add(s, t);
printf("%s + %s = %s\n", s.c_str(), t.c_str(), sum.c_str());
s = sum;
}
if (cnt == 10) {
printf("Not found in 10 iterations.\n");
} else {
printf("%s is a palindromic number.\n", s.c_str());
}
return 0;
}