PAT 1137. Final Grading (25)

For a student taking the online course “Data Structures” on China University MOOC (http://www.icourse163.org/), to be qualified for a certificate, he/she must first obtain no less than 200 points from the online programming assignments, and then receive a final grade no less than 60 out of 100. The final grade is calculated by G = (Gmid-termx 40% + Gfinalx 60%) if Gmid-term > Gfinal, or Gfinal will be taken as the final grade G. Here Gmid-term and Gfinal are the student’s scores of the mid-term and the final exams, respectively. The problem is that different exams have different grading sheets. Your job is to write a program to merge all the grading sheets into one.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers: P , the number of students having done the online programming assignments; M, the number of students on the mid-term list; and N, the number of students on the final exam list. All the numbers are no more than 10,000. Then three blocks follow. The first block contains P online programming scores Gp’s; the second one contains M mid-term scores Gmid-term’s; and the last one contains N final exam scores Gfinal’s. Each score occupies a line with the format: StudentID Score, where StudentID is a string of no more than 20 English letters and digits, and Score is a nonnegative integer (the maximum score of the online programming is 900, and that of the mid-term and final exams is 100).

Output Specification:

For each case, print the list of students who are qualified for certificates. Each student occupies a line with the format: StudentID Gp Gmid-term Gfinal G If some score does not exist, output “-1” instead. The output must be sorted in descending order of their final grades (G must be rounded up to an integer). If there is a tie, output in ascending order of their StudentID’s. It is guaranteed that the StudentID’s are all distinct, and there is at least one qualified student.

Sample Input:

6 6 7
01234 880
a1903 199
ydjh2 200
wehu8 300
dx86w 220
missing 400
ydhfu77 99
wehu8 55
ydjh2 98
dx86w 88
a1903 86
01234 39
ydhfu77 88
a1903 66
01234 58
wehu8 84
ydjh2 82
missing 99
dx86w 81

Sample Output:

missing 400 -1 99 99
ydjh2 200 98 82 88
dx86w 220 88 81 84
wehu8 300 55 84 84

解析见乙级:https://www.hdvsyu.com/posts/1413/

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
#include <cstdio>
#include <string>
#include <map>
#include <queue>

using namespace std;

struct node {
string id;
int gp, gm, gf, g;
};

map<string, int> kv;
node *students;

int main() {
int p = 0, m = 0, n = 0, index = 0, tnum = 0;
scanf("%d %d %d", &p, &m, &n);
students = new node[10010];
char tid[21];
for (int i = 0; i < p; i++) {
scanf("%s %d", tid, &tnum);
index++;
kv[tid] = index;
students[index].id = tid;
students[index].gp = tnum;
students[index].gf = students[index].gm = -1;
}

for (int i = 0; i < m; i++) {
scanf("%s %d", tid, &tnum);
if (kv[tid] != 0) {
students[kv[tid]].gm = tnum;
}
}
for (int i = 0; i < n; i++) {
scanf("%s %d", tid, &tnum);
if (kv[tid] != 0) {
students[kv[tid]].gf = tnum;
}
}

auto cmp = [](node a, node b) { return a.g != b.g ? a.g < b.g : a.id > b.id; };
priority_queue<node, vector<node>, decltype(cmp)> q(cmp);
for (int i = 1; i <= index; i++) {
if (students[i].gm > students[i].gf)
students[i].g = (int) (0.4 * students[i].gm + 0.6 * students[i].gf + 0.5);
else
students[i].g = students[i].gf;

if (students[i].gp >= 200 && students[i].g >= 60) {
q.push(students[i]);
}
}

while (!q.empty()) {
printf("%s %d %d %d %d\n", q.top().id.c_str(), q.top().gp, q.top().gm, q.top().gf, q.top().g);
q.pop();
}

return 0;
}