PAT 甲级 1002. A+B for Polynomials (25) C++版

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

把多项式的指数作为数组的下标,把系数进行累加,统计数组中系数不为0的个数就是最后多项式的项数。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
#include <cstdio>

int main() {
double ploy[1001] = {0.0};
int k = 0, n = 0, cnt = 0;
double an = 0;
for (int j = 0; j < 2; j++) {
scanf("%d", &k);
for (int i = 0; i < k; i++) {
scanf("%d %lf", &n, &an);
ploy[n] += an;
}
}

for (int i = 0; i <= 1000; i++) {
if (ploy[i] != 0.0) cnt++;
}

printf("%d", cnt);
for (int i = 1000; i >= 0; i--) {
if (ploy[i] != 0.0) {
printf(" %d %.1f", i, ploy[i]);
}
}
return 0;
}