PAT 乙级 1054. 求平均值 (20) Java版

本题的基本要求非常简单:给定N个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是[-1000,1000]区间内的实数,并且最多精确到小数点后2位。当你计算平均值的时候,不能把那些非法的数据算在内。

输入格式:

输入第一行给出正整数N(<=100)。随后一行给出N个正整数,数字间以一个空格分隔。

输出格式:

对每个非法输入,在一行中输出“ERROR: X is not a legal number”,其中X是输入。最后在一行中输出结果:“The average of K numbers is Y”,其中K是合法输入的个数,Y是它们的平均值,精确到小数点后2位。如果平均值无法计算,则用“Undefined”替换Y。如果K为1,则输出“The average of 1 number is Y”。

输入样例1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

输出样例1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

输入样例2:

2
aaa -9999

输出样例2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

这里用了抛异常的方式来判断输入的值是否符合规则

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
import java.util.Scanner;

public class Main {

public static void main(String[] args) {
Scanner in = new Scanner(System.in);
int n = in.nextInt();
int cnt = 0;
double y = 0;
for (int i = 0; i < n; i++) {
double x = 0;
String s = null;
try {
s = in.next();
x = Double.parseDouble(s);
double temp = Double.parseDouble(String.format("%.2f", x));
if (x > 1000 || x < -1000 || Math.abs(temp - x) >= 0.001) {
throw new NumberFormatException();
}

cnt++;
y += x;
} catch (NumberFormatException e) {
System.out.println("ERROR: " + s + " is not a legal number");
}
}
in.close();

if (cnt == 0) {
System.out.println("The average of 0 numbers is Undefined");
} else if (cnt == 1) {
System.out.printf("The average of 1 number is %.2f", y);
} else {
System.out.printf("The average of %d numbers is %.2f", cnt, y / cnt);
}
}

}