PAT 1123. Is It a Complete AVL Tree (30)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

Now given a sequence of insertions, you are supposed to output the level-order traversal sequence of the resulting AVL tree, and to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<= 20). Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, insert the keys one by one into an initially empty AVL tree. Then first print in a line the level-order traversal sequence of the resulting AVL tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line. Then in the next line, print “YES” if the tree is complete, or “NO” if not.

Sample Input 1:

5
88 70 61 63 65

Sample Output 1:

70 63 88 61 65
YES

Sample Input 2:

8
88 70 61 96 120 90 65 68

Sample Output 2:

88 65 96 61 70 90 120 68
NO

这里实际上是把AVL树和层序遍历两个考点放到了一起,判断是不是完全二叉树,就看在出现了一个孩子为空的结点之后,时候还会出现孩子结点不为空的结点,如果出现了就不是完全二叉树。AVL树理解起来可能比较复杂,但仔细看看就能够明白,一共有四种情况,这里我把发现树不平衡的那个结点叫做A结点,A发现树不平衡无非就是四种情况:

  1. 新来的结点插入到A的左子树的左子树
  2. 新来的结点插入到A的左子树的右子树
  3. 新来的结点插入到A的右子树的左子树
  4. 新来的结点插入到A的右子树的右子树

发现了不平衡那就要处理了,第1种情况只要简单的右旋就可以解决了,第4种情况只需左旋一下,剩下的第2、3种情况稍微复杂一点,第2种情况需要先对A的左子树左旋一下,然后对A右旋,同理第3种情况需要对A的右子树右旋一下,然后对A左旋,其他就没有什么大问题了,代码如下

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
#include <cstdio>
#include <vector>
#include <queue>

using namespace std;

struct Node {
int val;
struct Node *left, *right;
};

struct Node *leftRotate(struct Node *tree) {
struct Node *temp = tree->right;
tree->right = temp->left;
temp->left = tree;
return temp;
}

struct Node *rightRotate(struct Node *tree) {
struct Node *temp = tree->left;
tree->left = temp->right;
temp->right = tree;
return temp;
}

int getHeight(struct Node *tree) {
if (tree == NULL) {
return 0;
} else {
int l = getHeight(tree->left);
int r = getHeight(tree->right);
return l > r ? l + 1 : r + 1;
}
}

struct Node *leftRightRotate(struct Node *tree) {
tree->left = leftRotate(tree->left);
tree = rightRotate(tree);
return tree;
}

struct Node *rightLeftRotate(struct Node *tree) {
tree->right = rightRotate(tree->right);
tree = leftRotate(tree);
return tree;
}

struct Node *insert(struct Node *tree, int val) {
if (tree == NULL) {
tree = new struct Node();
tree->val = val;
return tree;
}
if (tree->val > val) {
tree->left = insert(tree->left, val);
int l = getHeight(tree->left);
int r = getHeight(tree->right);
if (l - r >= 2) {
if (val < tree->left->val) {
tree = rightRotate(tree);
} else {
tree = leftRightRotate(tree);
}
}
} else {
tree->right = insert(tree->right, val);
int l = getHeight(tree->left);
int r = getHeight(tree->right);
if (r - l >= 2) {
if (val > tree->right->val) {
tree = leftRotate(tree);
} else {
tree = rightLeftRotate(tree);
}
}
}
return tree;
}

int isComplete = 1, after = 0;

vector<int> levelOrder(struct Node *tree) {
vector<int> v;
queue<struct Node *> queue;
queue.push(tree);
while (queue.size() != 0) {
struct Node *temp = queue.front();
queue.pop();
v.push_back(temp->val);
if (temp->left != NULL) {
if (after) {
isComplete = 0;
}
queue.push(temp->left);
} else {
after = 1;
}
if (temp->right != NULL) {
if (after) {
isComplete = 0;
}
queue.push(temp->right);
} else {
after = 1;
}
}

return v;
}

void print(vector<int> v) {
for (int i = 0; i < v.size(); i++) {
if (i == 0) {
printf("%d", v[i]);
} else {
printf(" %d", v[i]);
}
}
printf("\\n");
}

int main() {
int n = 0;
scanf("%d", &n);
struct Node *tree = NULL;
for (int i = 0; i < n; i++) {
int temp = 0;
scanf("%d", &temp);
tree = insert(tree, temp);
}

vector<int> v = levelOrder(tree);
print(v);
if (isComplete) {
printf("YES");
} else {
printf("NO");
}
return 0;
}