PAT 1126. Eulerian Path (25)

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path) Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (<= 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph – either “Eulerian”, “Semi-Eulerian”, or “Non-Eulerian”. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:

7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6

Sample Output 1:

2 4 4 4 4 4 2
Eulerian

Sample Input 2:

6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6

Sample Output 2:

2 4 4 4 3 3
Semi-Eulerian

Sample Input 3:

5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3

Sample Output 3:

3 3 4 3 3
Non-Eulerian

题目的大意是判断给出的图是欧拉图、欧拉路径还是其他。 欧拉图即每个节点的度(入度和出度之和)都是偶数次的,不会出现奇数次的度的节点 欧拉路径即存在仅有两个节点的度为奇数次,其他节点的度皆为偶数次的节点 上述讨论欧拉图和欧拉路径的前提是这个图是连通的 isConnected使用广度优先搜索的策略进行搜索,从任意一个节点出发,做连续的广度优先搜索,如果不能遍历到所有的节点,就说明这个图不是连通的,即这个图即不是欧拉图也不是欧拉路径 isEulerian和isSemiEulerian都是通过对节点的度进行遍历,去统计奇数次节点的个数来得到结果的 最后打印出节点的度和结果

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
#include <cstdio>
#include <queue>

using namespace std;

int **graph, *degree;

void createArray(int n) {
graph = new int *[n];
for (int i = 0; i < n; i++) {
graph[i] = new int[n];
}
degree = new int[n];
}

void initializerArray(int n) {
for (int i = 0; i < n; i++) {
for (int j = 0; j < n; j++) {
graph[i][j] = 0;
}
degree[i] = 0;
}
}

void printDegree(int n) {
printf("%d", degree[0]);
for (int i = 1; i < n; i++) {
printf(" %d", degree[i]);
}
printf("\n");
}

bool isEulerian(int n) {
for (int i = 0; i < n; i++) {
if (degree[i] % 2 != 0) {
return false;
}
}
return true;
}

bool isSemiEulerian(int n) {
int cnt = 0;
for (int i = 0; i < n; i++) {
if (degree[i] % 2 != 0) {
cnt++;
}
}
return cnt == 2;
}

// bfs
bool isConnected(int n) {
int *isVisited = new int[n];
int pre = 0;
queue<int> q;
q.push(pre);
isVisited[pre] = true;
while (!q.empty()) {
pre = q.front();
q.pop();
for (int i = 0; i < n; i++) {
if (!isVisited[i] && graph[pre][i] == 1) {
q.push(i);
isVisited[i] = true;
}
}
}
for (int i = 0; i < n; i++) {
if (!isVisited[i]) {
return false;
}
}
return true;
}

int main() {
int n = 0, m = 0;
scanf("%d %d", &n, &m);
createArray(n);
initializerArray(n);
for (int i = 0; i < m; i++) {
int a = 0, b = 0;
scanf("%d %d", &a, &b);
graph[a - 1][b - 1] = graph[b - 1][a - 1] = 1;
degree[a - 1]++;
degree[b - 1]++;
}
printDegree(n);

if (isConnected(n)) {
if (isEulerian(n)) {
printf("Eulerian");
} else if (isSemiEulerian(n)) {
printf("Semi-Eulerian");
} else {
printf("Non-Eulerian");
}
} else {
printf("Non-Eulerian");
}
return 0;
}