PAT 1125. Chain the Ropes (25)

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2 <= N <= 104). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 104.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:

8
10 15 12 3 4 13 1 15

Sample Output:

14

用贪心的思想来解,最长的绳子折叠的次数越少越好。这里用到了优先队列priority_queue,它保证每次插入到队列中的值都是按顺序排列的,因此我们可以尽可能的找到最短的两条线段,折成新的绳子,然后继续找两个最短的绳子做折叠,直到只剩下一条绳子。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
#include <queue>
#include <cstdio>
#include <functional>
#include <vector>

using namespace std;

int main() {
int n = 0;
scanf("%d", &n);
priority_queue<int, vector<int>, greater<int> > q;
for (int i = 0; i < n; i++) {
int temp = 0;
scanf("%d", &temp);
q.push(temp);
}

while (q.size() > 1) {
int a = q.top();
q.pop();
int b = q.top();
q.pop();

q.push((a + b) / 2);
}
printf("%d", q.top());
}