PAT 1124. Raffle for Weibo Followers (20)

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo – that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (<= 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John’s post. Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print “Keep going…” instead.

Sample Input 1:

9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain

Sample Output 1:

PickMe
Imgonnawin!
TryAgainAgain

Sample Input 2:

2 3 5
Imgonnawin!
PickMe

Sample Output 2:

Keep going…

用map来记录一个用户是否已经获过奖了。当s > m,不满足抽奖规则,输出Keep going…;s <= m时,先输出第一个中奖的人,后面中奖的人根据根据规则继续往下推。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
#include <iostream>
#include <vector>
#include <string>
#include <map>

using namespace std;

int main() {
int m = 0, n = 0, s = 0;
cin >> m >> n >> s;
vector<string> forward(m + 1);
for (int i = 1; i <= m; i++) {
string nickname;
cin >> nickname;
forward[i] = nickname;
}

if (s > m) {
cout << "Keep going..." << endl;
} else {
map<string, bool> winner;
cout << forward[s] << endl;
winner[forward[s]] = true;
int i = s;
while (i < m) {
int cnt = 0;
while (i < m && cnt < n) {
i++;
if (!winner[forward[i]]) {
cnt++;
}
}
if (n == cnt) {
cout << forward[i] << endl;
winner[forward[i]] = true;
}
}
}
return 0;
}