蓝桥杯 ALGO-13 算法训练 拦截导弹 Java版

问题描述

  某国为了防御敌国的导弹袭击,发展出一种导弹拦截系统。但是这种导弹拦截系统有一个缺陷:虽然它的第一发炮弹能够到达任意的高度,但是以后每一发炮弹都不能高于前一发的高度。某天,雷达捕捉到敌国的导弹来袭。由于该系统还在试用阶段,所以只有一套系统,因此有可能不能拦截所有的导弹。 输入导弹依次飞来的高度(雷达给出的高度数据是不大于30000的正整数),计算这套系统最多能拦截多少导弹,如果要拦截所有导弹最少要配备多少套这种导弹拦截系统。

输入格式

  一行,为导弹依次飞来的高度

输出格式

  两行,分别是最多能拦截的导弹数与要拦截所有导弹最少要配备的系统数

样例输入

389 207 155 300 299 170 158 65

样例输出

6 2

【分析】第一个问题,最多能拦截的导弹数和最长不下降子序列是相似的。第二个问题,最少要配备的系统数需要用贪心算法来求解;对于最多能拦截的导弹数这个问题,每一枚飞来的导弹被系统拦截,那这一枚导弹后面比当前飞来的导弹高度低的导弹也可以被这套系统拦截,用一个dp数组来保存一套系统最多可以拦截多少导弹数;对于第二个问题,后面飞来的每一枚导弹,都用前面与它高度差最小的那套系统去拦截。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;

public class Main {
public static void main(String[] args) throws IOException {
BufferedReader reader = new BufferedReader(new InputStreamReader(System.in));
String[] missile = reader.readLine().split(" ");
reader.close();
int[] high = new int[missile.length];
for (int i = 0; i < high.length; i++) {
high[i] = Integer.parseInt(missile[i]);
}
System.out.println(getMaxIntercept(high));
System.out.println(getNumberOfIntercepter(high));
}

private static int getMaxIntercept(int[] high) {
int[] dp = new int[high.length];
int max = 0;
for (int i = 0; i < high.length; i++) {
for (int j = i + 1; j < high.length; j++) {
if (high[j] <= high[i]) {
dp[j] = Integer.max(dp[j], dp[i] + 1);
max = Integer.max(max, dp[j]);
}
}
}
return max + 1;
}

private static int getNumberOfIntercepter(int[] high) {
int numberOfIntercepter = 0;
boolean[] isIntercept = new boolean[high.length];
for (int i = 0; i < high.length; i++) {
int midHighDifference = getMinHighDifference(high, i, isIntercept);
if (midHighDifference == -1) {
numberOfIntercepter++;
} else {
isIntercept[midHighDifference] = true;
}
}
return numberOfIntercepter;
}

private static int getMinHighDifference(int[] high, int pos, boolean[] isIntercept) {
int minHighDifferenceIndex = -1;
for (int i = 0; i < pos; i++) {
if (!isIntercept[i] && high[i] >= high[pos]) {
if (minHighDifferenceIndex == -1 || high[i] < high[minHighDifferenceIndex]) {
minHighDifferenceIndex = i;
}
}
}
return minHighDifferenceIndex;
}
}