PAT 1135. Is It A Red-Black Tree (30)

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties: (1) Every node is either red or black. (2) The root is black. (3) Every leaf (NULL) is black. (4) If a node is red, then both its children are black. (5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes. For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (<=30) which is the total number of cases. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line “Yes” if the given tree is a red-black tree, or “No” if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No

判断一个树是否满足红黑树的性质。 find函数每次找到右子树的根节点,然后把树划分为左右子树,递归处理问题。getH获取树的高度。 solve4判断是否满足(4)条件,solve5判断是否满足(5)条件。 代码如下:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
#include <cstdio>
#include <vector>
#include <cstdlib>

using namespace std;

int find(vector<int> tree, int s, int e) {
int i = s + 1;
while (i <= e && abs(tree[s]) > abs(tree[i])) i++;
return i;
}

bool solve4(vector<int> tree, int s, int e) {
if (s > e) return true;
int i = find(tree, s, e);
if (tree[s] < 0) {
if (s + 1 <= e && tree[s + 1] < 0) return false;
if (i <= e && tree[i] < 0) return false;
}
return solve4(tree, s + 1, i - 1) && solve4(tree, i, e);
}

int getH(vector<int> tree, int s, int e) {
if (s > e) return 1;
int i = find(tree, s, e);
int l = getH(tree, s + 1, i - 1);
int r = getH(tree, i, e);
return tree[s] > 0 ? max(l, r) + 1 : max(l, r);
}

bool solve5(vector<int> tree, int s, int e) {
if (s > e) return true;
int i = find(tree, s, e);
int l = getH(tree, s + 1, i - 1);
int r = getH(tree, i, e);
if (l != r) return false;
return solve5(tree, s + 1, i - 1) && solve5(tree, i, e);
}

bool isRBT(vector<int> tree, int n) {
if (tree[0] < 0) return false;
if (!solve4(tree, 0, n - 1)) return false;
return solve5(tree, 0, n - 1);
}

int main() {
int k = 0, n = 0;
scanf("%d", &k);
vector<int> tree;
for (int i = 0; i < k; i++) {
scanf("%d", &n);
tree.resize(n);
for (int j = 0; j < n; j++) {
scanf("%d", &tree[j]);
}
if (isRBT(tree, n)) {
printf("Yes\n");
} else {
printf("No\n");
}
}
return 0;
}