PAT 甲级 1020. Tree Traversals (25) C++版

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

题目给出后序和中序,求确定的层序遍历。 getLevel中的while语句是找到根节点所在的位置,然后递归处理左子树和右子树。 变量l的作用是标记一个结点在树中的下标,找到根节点并把它存入一个指定的下标当中,最后输出的level就是层序遍历的结果。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
#include <cstdio>
#include <cstring>

int *post, *in, *level;

void getLevel(int s, int e, int r, int l) {
if (s > e) return;
int i = s;
while (i <= e && in[i] != post[r]) i++;
getLevel(s, i - 1, r - e + i - 1, 2 * l + 1);
getLevel(i + 1, e, r - 1, 2 * l + 2);
level[l] = post[r];
}

int main() {
int n = 0;
scanf("%d", &n);
post = new int[n], in = new int[n], level = new int[100000];
for (int i = 0; i < n; i++) {
scanf("%d", &post[i]);
}
for (int i = 0; i < n; i++) {
scanf("%d", &in[i]);
}
memset(level, -1, 100000);
getLevel(0, n - 1, n - 1, 0);
printf("%d", level[0]);
for (int i = 1; n > 1; i++) {
if (level[i] != -1) {
printf(" %d", level[i]);
n--;
}
}
delete[] level;
delete[] in;
delete[] post;
return 0;
}