PAT 1121. Damn Single (25)

“Damn Single (单身狗)” is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID’s which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (<=10000) followed by M ID’s of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID’s in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333

Sample Output:

5
10000 23333 44444 55555 88888

先用一个couple记录一对情侣,比如couple[11111]=22222,然后用一个guest数组存储接下来的一行guest,guest[i]表示这个guest的id,如果这个guest[i]的另一半不是-1,那么就设就告诉另一半,你来了,比如guest[i] != -1, 则设 isSCoupleAttent[guest[i]] = 1,比如guest[i] = 11111,那么isCoupleAttent[22222] = 1,表示是在guest数组里面的,最后遍历一下guest,看一下guest[i]的另一半是否出席了

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
#include <cstdio>
#include <set>
#include <iterator>

using namespace std;

int main() {
int n = 0;
scanf("%d", &n);
int *couple = new int[100000];
int *isCoupleAttent = new int[100000];
for (int i = 0; i < 100000; i++) {
couple[i] = -1;
isCoupleAttent[i] = 0;
}
for (int i = 0; i < n; i++) {
int a = 0, b = 0;
scanf("%d %d", &a, &b);
couple[a] = b;
couple[b] = a;
}
int m = 0;
scanf("%d", &m);
int *guest = new int[m];
for (int i = 0; i < m; i++) {
scanf("%d", &guest[i]);
if (couple[guest[i]] != -1) { isCoupleAttent[couple[guest[i]]] = 1; }
}
set<int> s;
for (int i = 0; i < m; i++) { if (!isCoupleAttent[guest[i]]) { s.insert(guest[i]); }}
printf("%d\n", s.size());
for (auto it = s.begin(); it != s.end(); it++) {
if (it != s.begin()) { printf(" "); }
printf("%05d", *it);
}
delete[] isCoupleAttent;
delete[] guest;
delete[] couple;

}