PAT 1122. Hamiltonian Cycle (25)

The “Hamilton cycle problem” is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a “Hamiltonian cycle”. In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2< N <= 200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format “Vertex1 Vertex2”, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format: n V1 V2 … Vn where n is the number of vertices in the list, and Vi’s are the vertices on a path.

Output Specification:

For each query, print in a line “YES” if the path does form a Hamiltonian cycle, or “NO” if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1

Sample Output:

YES
NO
NO
NO
YES
NO

闭合的哈密顿路径称作哈密顿回路(Hamiltonian cycle),含有图中所有顶点的路径称作哈密顿路径。 明白了什么是哈密顿回路,这个题目是不难了,首先给出的路径必须比题目给出的结点数大1,因为哈密顿路径经过图中所有顶点,而哈密顿回路则是在哈密顿路径的基础上回到起点,所以哈密顿回路的顶点数应该比给出的图的顶点大1。然后这个给出的哈密顿回路应该是在图中表现为连通的。最后,这个给出的哈密顿回路必须经过除起点外的其余结点一次,经过起点两次。 下面给出的代码用graph题目给出的图 isConnected方法测试给出的哈密顿回路在图中的连通性,pre表示前一个结点,v[i]表示当前结点,如果v[i]到pre在图中有路径则是连通的,否则就不连通的 isHamilt方法测试给出的哈密顿回路是不是哈密顿回路,第一个结点比如和最后一个结点相同才能满足闭合这个条件,times数组用来表示哈密顿回路中各结点出现的次数。如果除起始结点外,其余结点的出现次数不为1,则不是哈密顿回路,如果起始节点出现的次数不为2,则不是哈密顿回路

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
#include <cstdio>

int **graph;

int isConnected(int *v, int n) {
int pre = v[0];
for (int i = 1; i < n; i++) {
if (graph[pre][v[i]] != 1) {
return 0;
}
pre = v[i];
}
return 1;
}

int isHamilt(int *v, int n) {
if (v[0] != v[n - 1]) return 0;
int *times = new int[n];
for (int i = 0; i < n; i++) {
times[i] = 0;
}
for (int i = 0; i < n; i++) {
times[v[i]]++;
}

for (int i = 1; i < n; i++) {
if (i == v[0]) {
if (times[i] != 2) {
return 0;
}
} else {
if (times[i] != 1) {
return 0;
}
}
}
return 1;
}

int main() {
int n = 0, m = 0;
scanf("%d %d", &n, &m);
graph = new int *[n + 1];
for (int i = 0; i <= n; i++) {
graph[i] = new int[n + 1];
}
for (int i = 0; i <= n; i++) {
for (int j = 0; j <= n; j++) {
graph[i][j] = 0;
}
}
for (int i = 0; i < m; i++) {
int a = 0, b = 0;
scanf("%d %d", &a, &b);
graph[a][b] = graph[b][a] = 1;
}
int k = 0;
scanf("%d", &k);
for (int i = 0; i < k; i++) {
int kn = 0;
scanf("%d", &kn);
int *v = new int[kn];
for (int j = 0; j < kn; j++) {
scanf("%d", &v[j]);
}
if (kn == n + 1 && isConnected(v, kn) && isHamilt(v, kn)) {
printf("YES\n");
} else {
printf("NO\n");
}
}
return 0;
}